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Dreamweaver MX 
Full Tutorial 
 
What is Dreamweaver? 
 
Macromedia Dreamweaver is a professional Web Page editing program.  Whether your goal is to 
create a simple Web Page for a class, pursue a far larger project for a club or department, or just 
make a personal homepage for yourself, Dreamweaver provides a powerful, yet simple-to-use 
solution.  
 
Table of Contents 
 
A. Creating A New Web Page 
B. Editing Page Properties 
C. Understanding the Properties Inspector 
D. Text 
E. Images 
F. Links 

1. Hyperlinks 
2. E-mail Links 
3. Named Anchors 
4. Image Maps 

G. Tables 
1. Creating a Table 
2. Splitting & Merging Cells 
3. Adding & Deleting Rows or Columns 
4. Editing Other Table Properties 

H. Embedding a QuickTime Movie 
 
A. Creating A New Web Page 
 

1. To begin, open Macromedia Dreamweaver by clicking on the illustrated icon 
on the OSX dock. If you are using an OS9 or Windows XP system, you will 
find Dreamweaver listed under the Apple menu or Start menu 
respectively.  

2. Once Dreamweaver has loaded, you should see a workspace and several 
toolbars. The workspace will be displayed in the default, Design View. You 
can also toggle between the Code View and the Code and Design Views. 

 
Code View Design View 

Code & Design Views 

NOTE: The Code View displays what is known as HTML 
(Hypertext Markup Language). HTML is the underlying code for 
all of your Web Pages. While it is usually important to have 
some knowledge of HTML when creating Web Pages, for our 
simple purposes here it won’t be necessary. Dreamweaver, and 
other Web editors like it, allow you to use a simple graphical 
interface to type text and place objects, while the program 
itself writes the underlying code. 
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3. It is important to save your Web 
Page to a folder before you even 
begin working on it. You should 
create a folder that will contain 
not only your HTML files, but also 
any images, documents, or 
movies that you want to display 
on your page or link to from your 
page. Remember to keep all of 
these files within your folder, 
because separating them will 
cause your page to load 
incorrectly once it has been 
uploaded. To save your page, go 
to the File menu and select 
Save As. Title your page 
index.html. This will allow any 
Web browser to immediately 
recognize this page as your main 
page. Then, under the Where 
drop-down menu, find your folder and then click Save. 

 
B. Editing Page Properties 
 

1. To set the basic properties of 
your Web Page, go to the 
Modify menu and select Page 
Properties. 

2. Within the Page Properties 
dialogue box, there are many 
attributes of your page that you 
can edit.  However, we will 
focus on the most important 
ones here. These are Title, 
Background Color, Text Color, and Link Color.  You can also set the default colors for 
visited and active links, as well as change the margins of the page. 

3. The Title of your page is what will be displayed at the very top of the Web browser when 
people are viewing your page.  Therefore, you will want your title to be the name of your 
page, if you have one, or a summary of its contents.  In the example image, we have titled 
our page, “Study of African Bats.” Enter your desired title in this field. 

4. When setting default colors for the background, text, and 
links, there are two ways to accomplish this. First, you 
can enter the Hexadecimal code for the color in the field 
to the right of the heading. For instance, the background 
in our example image has been set to #666666, which 
corresponds to a medium gray color. Or, you can click on 
the colored box to the right of the heading and select 
your color from a list of 228 colors. The full color wheel of 
16.7 million colors can be accessed by click on the icon in
the top right of the color men

 
u. 
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NOTE: When setting the colors for your background, text, and links, be careful not to choose 
colors that are too bright or gaudy. You should aim for a professional look and feel to your 
page. Lime green as a background color is probably a poor choice. Likewise, make sure your 
text and links stand out from the background. If your text is hard to read, people won’t bother 
viewing your page. 
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5. Once you have set all of the attributes to your page in the Page Properties window, click 

Apply and then click OK. 
6. There are other options you can set in the Page Properties window, but these are the 

primary ones.  ALWAYS set your page properties before you begin working on your page. 
Often times, people forget to do this and end up lacking a title or setting text and link 
colors by hand, which is tedious and unnecessary. 

 
C. Understanding the Properties Inspector 
 

1. The Properties Inspector is what allows you to change the attributes of individual 
objects, once you begin adding text, images, tables, etc. to your Web Page.  The tools and 
fields available on the Properties Inspector will change depending on what type of object 
you have selected.  Here is an example of the tools and options available when a block of 
text has been highlighted. 

 

2. Notice the many options you have, such as font type, size, color, and style. You can control 
alignment and indentation.  Finally, there is also a field to enter a hyperlink and the option 
to created bulleted or numbered lists.  

3. If you were to highlight an image in your workspace, the Properties Inspector would 
change to display an entirely new list of attributes, applicable to the image object type.  

 
D. Text 
 

1. Text is entered and manipulated in Dreamweaver much in the same way as it is in your 
average word processing program like Microsoft Word.  However, there are some 
differences that we will mention here. 

 
• The <TAB> key will NOT indent text, because this is not a basic 

function of HTML.  If you want to indent a paragraph, use the 
Text Indent keys on the Properties Inspector once you have 
typed your text. 

• Pressing the <RETURN> key drops your cursor down two line spaces instead of one. 
In order to drop down a single line space, press <SHIFT> + <RETURN>. 

• Individual fonts are NOT assigned to text. Rather, a Font Set is assigned to text to 
ensure that all versions of different browsers on both Mac and PC computers will be 
able to recognize at least one font in the set you choose. 

• Font sizes do NOT run on the normal scale with a 12 pt. default.  Rather, fonts are 
sized on a 1-7 scale with size 3 being the default. 

• To underline text, you must go to the Text menu, select Style, and then choose 
Underline.  There is no hot key combination to underline text (such as <CTRL> + 
<U>) in Dreamweaver. 

 
2. All other text manipulation should be familiar to you.  To change font sizes, colors, styles, 

etc, use the Properties Inspector. 
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E. Images 
 
NOTE: Web browsers will only recognize certain types of images. If you are going to insert images 
into your Web Page, make sure that they are either in JPEG or GIF format.  
  

1. To insert an image into your Web Page, go to the Insert menu and select Image. 
Navigate through your computer’s folder structure and locate the desired image file.  Select 
it and click Choose. 

2. Now that the image has been inserted into your page, 
click on it and notice how the attributes available for 
editing in the Properties Inspector have changed. Here, 
you can add a border to your image, set its alignment, or 
change its dimensions. 

3. If you want to resize an image, remember that it is important to constrain its proportions in 
order to avoid distortion. Click on your image to select it. Now, while holding down the 
<SHIFT> key, click on the handle at the bottom right of the image and drag to either 
shrink or enlarge the image. Notice how the proportions are constrained.  

 
NOTE: Increasing the size of an image will significantly reduce image quality. It is wise to exercise 
discretion when choosing to do this.   
 
NOTE: You cannot place the image anywhere you wish on the Web Page using wrap settings like 
in Microsoft Word.  You are constrained to the different alignment settings.  If you wish to 
increase image placement flexibility, you might want to consider using a table as a layout device 
or using drawing layers. 

 
F. Links 
 

1. Hyperlinks 
a. In order to create a hyperlink to a page outside of your site, a page within your site, or 

a document or other file, you need to begin by selecting the body of text or image you 
wish to make into a link. 

b. Once you have done this, go to the Properties Inspector and locate the text entry 
field that has Link written next to it.  It will look something like this. 

 
c. If you are linking to a Web Page outside of your site, you will need to enter the full http 

address. Here is an example: http://www.cnn.com/. 
d. If you are linking to another page within your site, you simply need to enter the name 

of the file.  Again, here is an example: biography.html. 
 

NOTE: If your Web Site includes folders to organize your different pages, images, and documents, 
you will need to be sure to include the folder structure in your link entry.  For instance, if 
biography.html were located in the folder personal, then you would type the following in the 
Link text box: personal/biography.html. 

 
e. If you are linking to a document or other file type, again, simply enter the name of the 

file.  Here is an example: myessay.doc. 
 

NOTE: Any files, HTML or other, that reside within your folder in your Web space do not need the 
full http address for the link to recognize the file.  If you do type out the full address, the link will 
still work; it just takes less time to type out the file name rather than the entire address when this 
isn’t required. 
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2. E-Mail Links 
a. To create an e-mail link, start the same way as before by selecting a block of text or an 

image.  
b. Go to the Properties Inspector and locate the Link entry field.  
c. Inside the field, type “mailto:” followed by the e-mail address you wish the link to 

connect to.  Now, when a user clicks your link, it will open his/her default e-mail 
program and insert the given e-mail address into his/her send field.  An example of the 
entire entry will look something like this: mailto:jronald@hamilton.edu. 

 
3. Named Anchors 

a. A named anchor is a link that one uses to jump to another point within the same page 
or to a specific point on another page.  Named anchors are commonly used when the 
amount of text on a page is significant and continual scrolling is required to go from the 
top of the page to the bottom.  By using a named anchor next to a table of contents 
item, you can allow the user to automatically jump to the location on the page where 
that specific information is located. 

b. To insert a named anchor, begin by finding the location on the page where you want 
the link to jump to, NOT where you want to place the actual link! 

c. Go to the Insert menu and select Named Anchor.  In the dialogue box that appears, 
enter the name for this anchor.  Use a name that relates the anchor to the information 
with which it corresponds.  Then click OK.  Note the example.  The golden anchor 
symbol is the anchor that was inserted next to “Item 7”. So, we aptly title this anchor, 
item7. 

d. Now, go to the point on your page where you want to insert the link that will jump to 
your named anchor.  Once you have selected the block of text or image that you want 
to create into the link, simply type # by pressing <SHIFT> + <3> and then the name 
of the anchor in the Link field in the Properties Inspector. Your entry should look 
something like this: #item7. 

 
4. Image Maps 

a. An image map is an image that has several Hotspots 
(individual areas of the image that are links to different 
Web Pages or files).  To create an image map, select the 
image you wish to create the hotspots on. 

b. Go to the Properties Inspector and locate the 
following portion in the bottom left corner.  Notice the 
three buttons illustrating blue shapes.  You can use these to create a Rectangular 
Hotspot, an Oval Hotspot, or an irregularly shaped Polygon Hotspot on your image. 

c. Select the tool you want and draw the shape around the portion of the image you wish 
to create into a link by clicking and dragging. 

 
NOTE: By holding down the <SHIFT> key while using the 
Rectangular or Oval Hotspot tools, you can create a 
perfect square or circle. 

 
d. Once you have created your hotspot, you can 

adjust its borders by clicking on one of the 
corner handles and dragging. 

e. Now, with the hotspot selected, enter the link 
into the Link field in the Properties 
Inspector.  You can use hotspots as named 
anchor links, e-mail links, or regular hyperlinks 
to pages, documents, and other files. 
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G. Tables 
 

1. Creating a Table 
a. Tables are used often in Web Pages for many reasons.  They are an excellent way to 

organize your information, control the layout of your page, and provide a more 
professional look and feel to your Web Page. 

b. To insert a table, go to the Insert menu and select Table.  The Insert Table dialogue 
box should appear. 

c. In this dialogue box, you can control several attributes of your table.  First, you can set 
the number of Rows and Columns that your table will contain.  Second, you can choose 
whether or not to use Cell Padding or Cell Spacing.  You can set the Width of your table 
in either pixels or as a percentage of the total width of your Web Page.  Finally, you can 
choose whether or not to include a Border with your table.  Once you have set all of the 
attributes, click OK. 

 
NOTE: By setting your Border value at 
0, you will retain the organizing 
capabilities of the table without having 
to see its borders.  This is useful if you 
are using the table as a means to 
organize the layout of your page. While 
working in Dreamweaver’s workspace, 
you will see a dotted line bordering your 
table. This border will not be visible once 
you upload your page and view it in a 
Web browser.  

 
2. Splitting & Merging Cells 

a. Once you have created your table, you can split a cell in two or merge two or more cells 
together if it suits your needs.  

b. To split a cell, select the cell of the table you wish to split by clicking in it. Go to the 
Modify menu, select Table, and then choose Split Cell.  A dialogue box will appear 
asking whether you wish to split the cell into rows or columns and how many splits to 
make.  Enter this information and click OK. 

c. To merge cells, select the grouping of cells you wish to merge together by clicking and 
dragging to highlight them.  Go to the Modify menu, select Table, and then choose 
Merge Cells.  This will automatically merge all of the selected cells into one large cell. 

 
3. Adding & Deleting Rows or Columns 

a. You can add rows and columns in much the same way that you split and merged cells.  
To add rows or columns, begin by selecting a cell in the row beneath where you want 
the new row added, or a cell in the column to the right of where you want the new 
column added. 

b. Go to the Modify menu, select Table, and then choose Insert Row or Insert 
Column, depending on your desired action.  The new column or row will now be added. 

c. If you wish to delete a row or column from your table, simply select a cell within that 
row or column, go to the Modify menu, select Table, and then choose Delete Row or 
Delete Column, depending on your desired action.  The column or row you selected 
will now be deleted. 

 
4. Editing Other Table Properties 

a. If you wish to edit the table properties, hover the cursor over the outside border of the 
table until you see the double arrowhead.  Now click once.  The entire table has been 
selected. 
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b. Go to the Properties Inspector and notice the many attributes you can change, such 
as width, height, alignment, border, border color, background color, etc. 
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c. If you wish to edit individual cell properties, simply click the desired cell and again 
revert to the Properties Inspector. Here you can control the alignment of text and 
objects within the cell, the border and background colors of the cell, etc. 

 
H. Embedding a QuickTime Movie 
 

1. To embed a QuickTime movie in your Web Page, refer to the document, “Embedding Video 
into a Web Page,” in the ITS Technology Support System.  You can find this document by 
going to http://www.hamilton/edu/college/its and searching for Web Page in the 
Technology Support Search box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

For questions or comments regarding this document, please e-mail docxteam@hamilton.edu. 

http://www.hamilton/edu/college/its
mailto:docxteam@hamilton.edu
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